Probleme: installer Owncloud Sync Client sur linux Mint 17.3

voir l’article original sur le forum de linux Mint

Problems installing Owncloud Sync Client on 17.3

La version installée de owncloud-client  est incompatible avec un serveur récent. De plus si on essaye d’installer à partir de nouveaux dépôts (merci Google) on a des incompatibilités de bibliothèques, du genre

owncloud-client : Depends: libowncloudsync0 (= 2.2.2-18.2) but it is not going to be installed
Depends: libqt5core5a (>= 5.5.0) but 5.2.1+dfsg-1ubuntu14.3 is to be installed
Depends: libqt5keychain1 but it is not going to be installed
Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is to be installed
Depends: owncloud-client-l10n but it is not going to be installed

La solution

Enlever les dépôts existants

sudo rm /etc/apt/sources.list.d/owncloud-client.list
sudo rm /etc/apt/sources.list.d/owncloud.list
apt purge owncloud*

Ajouter les bons dépôts

echo "deb http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Ubuntu_14.04/ /" | sudo tee /etc/apt/sources.list.d/owncloud-client.list

sudo apt-get update

Réinstaller

apt install owncloud-client

Et voilà  ; merci à Laurent85 https://forums.linuxmint.com